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Preface

About This Guide

This lab covers the creation and implementation of a single chip crypto (SCC) system, 
utilizing an isolated, redundant AES module. Complete step-by-step instructions are given 
for the entire process.

Guide Contents
This manual contains the following chapters:

• Chapter 1, Design Challenge, describes the SCC design and the goals of the lab.

• Chapter 2, Synthesizing Modules for Partial Reconfiguration Flow, describes the steps 
in the bottom-up synthesis flow.

• Chapter 3, Floorplanning the System, gives step-by-step instructions for 
implementing the SCC design.

• Chapter 4, Running the Isolation Verification Tool Against the UCF, covers running 
the Isolation Verification Tool (IVT) against the pre-placed-and-routed design.

• Chapter 5, Implementing the Design with the PlanAhead Tool, details placing and 
routing the SCC design.

• Chapter 6, Verifying the Design with the NCD Isolation Verification Tool, describes 
running the verification tool on the placed-and-routed design.

• Appendix A, Modified Implementation of the PlanAhead Tool 12.1, describes a 
modified method for implementing the design using the PlanAhead™ tool 12.1.

Additional Resources
To find additional documentation, see the Xilinx website at:

http://www.xilinx.com/support/documentation/index.htm.

To search the Answer Database of silicon, software, and IP questions and answers, or to 
create a technical support WebCase, see the Xilinx website at:

http://www.xilinx.com/support/mysupport.htm.

http://www.xilinx.com
http://www.xilinx.com/support/documentation/index.htm
http://www.xilinx.com/support/mysupport.htm
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Preface: About This Guide

Conventions
This document uses the following conventions. An example illustrates each convention.

Typographical
The following typographical conventions are used in this document:

Online Document
The following conventions are used in this document:

Convention Meaning or Use Example

Courier font
Messages, prompts, and 
program files that the system 
displays

speed grade: - 100

Courier bold
Literal commands that you enter 
in a syntactical statement

ngdbuild design_name

Helvetica bold

Commands that you select from 
a menu

File →  Open

Keyboard shortcuts Ctrl+C

Italic font

Variables in a syntax statement 
for which you must supply 
values

ngdbuild design_name

References to other manuals See the Command Line Tools User 
Guide for more information.

Emphasis in text
If a wire is drawn so that it 
overlaps the pin of a symbol, the 
two nets are not connected.

Convention Meaning or Use Example

Blue text
Cross-reference link to a location 
in the current document

See the section “Additional 
Resources” for details.

Refer to “Title Formats” in 
Chapter 1 for details.

Blue, underlined text Hyperlink to a website (URL)
Go to http://www.xilinx.com 
for the latest speed files.

http://www.xilinx.com


SCC Lab with Virtex-5 Family for ISE Tools 12.1 www.xilinx.com 7
XAPP1105 (v1.1.2) June 19, 2013

Chapter 1

Design Challenge

From the instructions in this chapter, a single chip crypto system can be created and 
implemented utilizing an isolated, redundant Advanced Encryption Standard (AES) 
module targeting a Virtex®-5 or Virtex-5Q FPGA utilizing the ISE® Design Suite 12.1 and 
the PlanAhead™ design tools 12.1. It is necessary to use the ISE design suite 12.1 for this 
lab. Figure 1-1 is a hierarchical diagram of the various VHDL sub-blocks used in the 
implementation of the design. This single chip crypto lab shows how to develop a 
dual-AES design. The user can expand upon this to create their own custom design based 
on the design methodology.

Type 1 Virtex-5 FPGA crypto applications require defense-grade (XQ) devices for mask 
control. The design example used in this application note was created using a non-defense-
grade Virtex-5 XC5VLX85-FF676-2 device.

X-Ref Target - Figure 1-1

Figure 1-1: VHDL Design Hierarchical Block Diagram

SCC_LAB_TOP

AES AES_R

KEY_EXPANDER

COMPARE

X1105_c1_01_061710

KEY_EXPANDER

http://www.xilinx.com
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Chapter 1: Design Challenge

Figure 1-2 shows the design flow used for the single chip crypto lab.

Figure 1-3 shows the partitioning and I/O mapping for an XC5VLX85-2FF676 device.

Figure 1-4 is a view of the completed XSCC reference design displayed in the Xilinx® 
FPGA Editor tool. The design incorporates two AES algorithm blocks: aes and aes_r. 
Both of the AES blocks are driven by the same input data and key. In Figure 1-4, the two 
AES blocks are the sideways C-shaped regions. Both of the AES blocks are tied to the 
compare block, which compares the outputs of the AES blocks. If the outputs of the AES 

X-Ref Target - Figure 1-2

Figure 1-2: SCC System Design Flow

X-Ref Target - Figure 1-3

Figure 1-3: Die View: Partition and I/O Map of XC5VLX85-2FF676

Module Synthesis

System Floorplanning

Timing Analysis

IVT on UCF File

Design Implementation

IVT on NCD File

X1105_c1_02_061710

AES

AES_R

COMPARE

clk

reset

push_button

led

X1105_c1_03_061710

http://www.xilinx.com
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blocks do not match, the compare block sends an alert to the user indicated by an LED. 
Both AES blocks have an input that allows the user to inject an error. However, only the 
aes block has the error injection input tied to an external pushbutton.

X-Ref Target - Figure 1-4

Figure 1-4: FPGA Editor View: Implementation of the Single Chip Crypto Flow

X1105_c1_04_061810

http://www.xilinx.com
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Chapter 1: Design Challenge

Reference Design Files

Reference Design Checklist
The design files for this application note can be downloaded from:

https://secure.xilinx.com/webreg/clickthrough.do?cid=343383

The design checklist in Table 1-1 includes simulation, implementation, and hardware 
details for the reference design.

Table 1-1: Design Checklist

Parameter Description

General

Developer Name Xilinx

Target devices Virtex-5 LX85 FPGA

Source code provided Y

Source code format VHDL

Design uses code/IP from existing Xilinx application note/ 
reference designs, CORE Generator™ software, or third party

N

Simulation

Functional simulation performed Y

Timing simulation performed Y

Testbench used for functional and timing simulations Y

Testbench format VHDL

Simulator software/version used ISE design suite 12.1

SPICE/IBIS simulations N

Implementation

Synthesis software tools/version used XST 12.1

Implementation software tools/versions used ISE design suite 12.1

Static timing analysis performed Y

Hardware Verification

Hardware verified N

Hardware platform used for verification N/A

https://secure.xilinx.com/webreg/clickthrough.do?cid=343383
http://www.xilinx.com
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Reference Design Files

Installing Reference Design Files into Target Directories
These steps describe the process for installing the reference design files:

Note: It is best if the design files are unzipped onto a directory without any spaces in the path.

1. Copy XAPP1105.zip to the Windows desktop.

2. Double-click on XAPP1105.zip and unzip the contents to the desired location.

3. The project files are placed in the following directories:

\Xilinx_Design\source\
\Xilinx_Design\ivt
\Xilinx_Design\synthesis\
\Xilinx_Design\PlanAhead
\Xilinx_Design\BuildScripts
\Xilinx_Design\results

http://www.xilinx.com
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Chapter 2

Synthesizing Modules for Partial 
Reconfiguration Flow

This chapter describes the steps that take the user through a bottom-up synthesis flow, 
which is the flow used for SCC designs to maintain isolation. The top module 
(SCC_LAB_TOP) is synthesized first, followed by each of the lower-level modules (aes, 
aes_r, and compare).

Synthesize the SCC_LAB_TOP Module
These steps describe how to synthesize the SCC_LAB_TOP module:

1. Start the ISE® design suite 12.1:

Start → All Programs → Xilinx ISE Design Suite 12.1 → ISE Design Tools → 
Project Navigator

2. Create a new ISE design suite 12.1 project:

File → New Project

http://www.xilinx.com
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Chapter 2: Synthesizing Modules for Partial Reconfiguration Flow

3. Set the project location to \Xilinx_Design\synthesis.

4. Set the project name to SCC_LAB_TOP.

5. Click Next (see Figure 2-1).
X-Ref Target - Figure 2-1

Figure 2-1: New Project Wizard (Create New Project)

X1105_c2_01_061810

http://www.xilinx.com
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Synthesize the SCC_LAB_TOP Module

6. Choose an XC5VLX85-FF676-2 FPGA as the target device (see Figure 2-2).

7. Click Next.

X-Ref Target - Figure 2-2

Figure 2-2: New Project Wizard (Project Settings)

X1105_c2_02_061810

http://www.xilinx.com
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Chapter 2: Synthesizing Modules for Partial Reconfiguration Flow

8. Click Finish in the Project Summary window (see Figure 2-3).
X-Ref Target - Figure 2-3

Figure 2-3: New Project Wizard (Project Summary)

X1105_c2_03_061810

http://www.xilinx.com
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Synthesize the SCC_LAB_TOP Module

9. Select the Add Source button on the left side of the Design window in the Project 
Navigator of the ISE tool (see Figure 2-4).

X-Ref Target - Figure 2-4

Figure 2-4: Project Navigator Window (Add Existing Sources)

X1105_c2_04_062210

http://www.xilinx.com
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Chapter 2: Synthesizing Modules for Partial Reconfiguration Flow

10. Navigate to the source\design directory, and add the top_package.vhd and 
SCC_LAB_TOP.vhd files to the project (see Figure 2-5). Click OK.

X-Ref Target - Figure 2-5

Figure 2-5: Adding Source Files

X1105_c2_05_061910

http://www.xilinx.com
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Synthesize the SCC_LAB_TOP Module

The Project Navigator window should look like the one shown in Figure 2-6.

Note: The question marks (?) by all blocks that are not coded at the top level are expected because 
only the top level is being synthesized at this time. All other blocks are out of context and are treated 
as black boxes.

X-Ref Target - Figure 2-6

Figure 2-6: Project Navigator Window

X1105_c2_06_061910

http://www.xilinx.com
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Chapter 2: Synthesizing Modules for Partial Reconfiguration Flow

11. Open the SCC_LAB_TOP.vhd file and locate the buffer_type attributes:

attribute buffer_type: string;
attribute buffer_type of push_button : signal is "none";
attribute buffer_type of reset : signal is "none";
attribute buffer_type of led         : signal is "none";

The buffer_type attribute directs the Xilinx® Synthesis Technology (XST) synthesis 
tool to disable I/O insertion on these ports. The buffer_type attribute is necessary to 
guarantee that I/Os are included in the lower-level modules, and therefore are part of 
the isolated regions. However, in SCC_LAB_TOP.vhd, clk is driven to all modules. 
Clock networks are not required to be isolated. As such, this attribute should not be 
applied to the CLK pin of the top-level code.

12. Right-click on the Synthesize-XST icon in the Processes window and select Process 
Properties…. Set Optimization Goal to Area, set Optimization Effort to High, and 
click OK (see Figure 2-7). Keep Hierarchy does not have to be set on this module for 
this flow.

http://www.xilinx.com
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Synthesize the SCC_LAB_TOP Module

13. To run XST synthesis, either right-click on the Synthesize-XST icon in the Processes 
window and click Run, or double-click Synthesize-XST. After synthesis is complete, 
close the project.

X-Ref Target - Figure 2-7

Figure 2-7: Process Properties (Synthesis Options)

X1105_c2_07_061910

http://www.xilinx.com
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Chapter 2: Synthesizing Modules for Partial Reconfiguration Flow

Synthesize the aes Module
These steps describe how to synthesize the aes module:

1. Start the ISE design suite 12.1.

Start → All Programs → Xilinx ISE Design Suite 12.1 → ISE Design Tools → 
Project Navigator

2. Create a new ISE design suite 12.1 project:

File → New Project

3. Set the project location to \Xilinx_Design\synthesis.

4. Set the Project Name to aes.

5. Click Next (see Figure 2-8).
X-Ref Target - Figure 2-8

Figure 2-8: New Project Wizard (Create New Project)

X1105_c2_08_061910

http://www.xilinx.com
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Synthesize the aes Module

6. Click Next (see Figure 2-9).

7. Click Next.

X-Ref Target - Figure 2-9

Figure 2-9: New Project Wizard (Project Settings)

X1105_c2_09_061910

http://www.xilinx.com
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Chapter 2: Synthesizing Modules for Partial Reconfiguration Flow

8. Click Finish in the Project Summary window (see Figure 2-10).
X-Ref Target - Figure 2-10

Figure 2-10: New Project Wizard (Project Summary)

X1105_c2_10_061910

http://www.xilinx.com
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Synthesize the aes Module

9. Select the Add Source button on the left side of the Design window in the Project 
Navigator of the ISE tool (see Figure 2-11).

X-Ref Target - Figure 2-11

Figure 2-11: Project Navigator (Add Existing Sources)

X1105_c2_11_061910
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Chapter 2: Synthesizing Modules for Partial Reconfiguration Flow

10. Navigate to the source\design directory and add the aes.vhd, 
aes_package.vhd, and key_expander.vhd files to the project (see Figure 2-12). 
Click OK.

X-Ref Target - Figure 2-12

Figure 2-12: Adding Source Files

X1105_c2_12_061910

http://www.xilinx.com
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The Project Navigator window should look like the one shown in Figure 2-13.

Note: All blocks are defined. There should be no question marks (?) by any module. All modules at 
this level and below are in context.

11. Open the aes.vhd file and locate the section containing the buffer_type attributes:

attribute buffer_type: string;
attribute buffer_type of clk         : signal is "none";
attribute buffer_type of start       : signal is "none";
attribute buffer_type of mode        : signal is "none";
attribute buffer_type of load        : signal is "none";
attribute buffer_type of key         : signal is "none";

X-Ref Target - Figure 2-13

Figure 2-13: Project Navigator Window
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attribute buffer_type of data_in     : signal is "none";
attribute buffer_type of reset_out : signal is "none";
attribute buffer_type of data_out    : signal is "none";
attribute buffer_type of done        : signal is "none";

The buffer_type attribute directs XST to disable I/O insertion on the specified ports. By 
default, XST inserts an I/O on all ports. The buffer_type attribute is necessary to 
guarantee I/Os are not placed at this level in the hierarchy either because the I/Os are 
placed at the top level (such as CLK) or because the port is a direct connection to a port 
of another instance. 

Note: The reset and push_button signals do not have an attribute associated with them 
because they are “owned” by aes and therefore require an I/O to be inferred within the aes 
module rather than within SCC_LAB_TOP. The clk I/O was inferred when SCC_LAB_TOP was 
synthesized. The other signals are internal to the FPGA; therefore they have the attribute 
signal is "none" applied.

12. In the aes.vhd source code file, the LUT instantiation between reset and reset_out is 
necessary for Trusted Routing rules. Refer to XAPP1134, Developing Secure Designs 
Using the Virtex®-5 Family, for more details on Trusted Routing rules. A section of the 
VHDL code for the LUT instantiation is shown here:
-- Instantiate LUT buffers on nets that either drive two different regions
-- or are feedthrough's from one region to the next. This prevents a single
-- net being placed "shorting" three regions together. Trusted Bus Macros
-- fulfilled this requirement automatically.

lut_reset_out : LUT1
GENERIC MAP (INIT => X"2")
PORT MAP (I0 => reset, O => reset_out );

13. Right-click on the Synthesize-XST icon in the Processes window and select 
Process Properties….
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14. Set Optimization Goal to Area, set Optimization Effort to High, and click OK (see 
Figure 2-14).

15. To run XST synthesis, either right-click on the Synthesize-XST icon in the Processes 
window and select Run or simply double-click Synthesize-XST.

16. After synthesis is complete, close the aes project.

X-Ref Target - Figure 2-14

Figure 2-14: Process Properties
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Synthesize the aes_r Module
These steps describe how to synthesize the aes_r module:

1. Start the ISE design suite 12.1:

Start → All Programs → Xilinx ISE Design Suite 12.1 → ISE Design Tools → 
Project Navigator

2. Create a new ISE 12.1 project:

File → New Project

3. Set the Project Location to \Xilinx_Design\synthesis.

4. Set the Project Name to aes_r.

5. Click Next (see Figure 2-15).
X-Ref Target - Figure 2-15

Figure 2-15: New Project Wizard (Create New Project)
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6. Choose an XC5VLX85-FF676-2 as the target device (see Figure 2-16).

7. Click Next.

X-Ref Target - Figure 2-16

Figure 2-16: New Project Wizard (Project Settings)
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8. Click Finish in the Project Summary window (see Figure 2-17).
X-Ref Target - Figure 2-17

Figure 2-17: New Project Wizard (Project Summary)
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9. Select the Add Source button on the left side of the Design window in the ISE software 
Project Navigator, as shown in Figure 2-18.

X-Ref Target - Figure 2-18

Figure 2-18: Project Navigator (Add Existing Sources)
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10. Navigate to the source\design directory, and add the aes_r.vhd, 
aes_package.vhd, and key_expander.vhd files to the project (see Figure 2-19). 
Click OK.

X-Ref Target - Figure 2-19

Figure 2-19: Adding Source Files
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The ISE Project Navigator Window should look like the window shown in Figure 2-20.

Note: All modules are defined. There should be no question marks (?) by any module. All modules 
at this level and below are in context.

11. Open the aes_r.vhd file and locate the section containing the buffer_type attributes:

attribute buffer_type: string;
attribute buffer_type of clk         : signal is "none";
attribute buffer_type of reset       : signal is "none";
attribute buffer_type of push_button : signal is "none";
attribute buffer_type of start       : signal is "none";
attribute buffer_type of mode        : signal is "none";
attribute buffer_type of load        : signal is "none";
attribute buffer_type of key         : signal is "none";
attribute buffer_type of data_in     : signal is "none";
attribute buffer_type of data_out    : signal is "none";
attribute buffer_type of done        : signal is "none";

X-Ref Target - Figure 2-20

Figure 2-20: Project Navigator Window
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The buffer_type attribute directs XST to disable I/O insertion on the specified ports. By 
default, XST inserts an I/O on all ports. The buffer_type attribute is necessary to 
prevent this insertion at this level in the hierarchy either because the I/Os are placed at 
the top level (such as CLK) or the port is a direct connection to a port of another 
instance.

Note: The clk I/O is inferred when SCC_LAB_TOP is synthesized. All other ports are internal to 
the FPGA; therefore they have the attribute signal is "none" applied.

12. Right-click the Synthesize-XST icon in the Processes window and select Process 
Properties….
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13. Set Optimization Goal to Area, set Optimization Effort to High, and click OK (see 
Figure 2-21).

14. To run XST synthesis, either right-click on the Synthesize-XST icon in the Processes 
window and select Run, or double-click Synthesize-XST.

15. After synthesis is complete, close the aes_r project.

X-Ref Target - Figure 2-21

Figure 2-21: Process Properties
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Synthesize the compare Module
These steps describe how to synthesize the compare module:

1. Start the ISE design suite 12.1:

Start → All Programs → Xilinx ISE Design Suite 12.1 → ISE Design Tools → 
Project Navigator

2. Create a new ISE design suite 12.1 project:

File → New Project

3. Set the project location to \Xilinx_Design\synthesis.

4. Set the project name to compare.

5. Click Next (see Figure 2-22).
X-Ref Target - Figure 2-22

Figure 2-22: New Project Wizard (Create New Project)
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6. Choose an XC5VLX85-FF676-2 as the target device (see Figure 2-23).

7. Click Next.

X-Ref Target - Figure 2-23

Figure 2-23: New Project Wizard (Project Settings)
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8. Click Finish in the Project Summary window (see Figure 2-24).
X-Ref Target - Figure 2-24

Figure 2-24: New Project Wizard (Project Summary)
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9. Select the Add Source button on the left side of the Design window in the Project 
Navigator of the ISE tool (see Figure 2-25).

X-Ref Target - Figure 2-25

Figure 2-25: Project Navigator (Add Existing Sources)
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10. Navigate to the source\design directory, and add the compare.vhd file to the 
project (see Figure 2-26). Click OK.

X-Ref Target - Figure 2-26

Figure 2-26: Adding Source Files
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The ISE Project Navigator Window should look like the window shown in Figure 2-27.

Note: All modules are defined. There should be no question marks (?) by any module. All modules 
at this level and below are in context.

11. Open the compare.vhd file and locate the buffer attributes:

attribute buffer_type: string;
attribute buffer_type of clk          : signal is "none";
attribute buffer_type of reset        : signal is "none";
attribute buffer_type of reset_out    : signal is "none";
attribute buffer_type of done1        : signal is "none";
attribute buffer_type of done2        : signal is "none";
attribute buffer_type of start        : signal is "none";

X-Ref Target - Figure 2-27

Figure 2-27: Project Navigator Window
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attribute buffer_type of load         : signal is "none";
attribute buffer_type of data_in1     : signal is "none";
attribute buffer_type of data_in2     : signal is "none";

The buffer_type attribute directs XST to disable I/O insertion on the specified ports. By 
default, XST inserts an I/O on all ports. The buffer_type attribute is necessary to 
prevent this insertion at this level in the hierarchy either because the I/Os are placed at 
the top level (such as CLK) or because the port is a direct connection to a port of 
another instance.

Note: The LED signal does not have an attribute associated with it because the LED signal is 
driven directly by an output buffer from within the compare code. All other ports are either ports 
within the FPGA or had their I/Os inferred at a different level; therefore, they have the attribute 
signal is "none" applied.

12. In the compare.vhd source code file, the LUT instantiation between certain inputs 
and outputs is necessary for Trusted Routing rules. Refer to XAPP1134, Developing 
Secure Designs Using the Virtex-5 Family, for more details on Trusted Routing rules. A 
section of the VHDL code for the LUT instantiation is shown here:
-- Instantiate LUT buffers on nets that either drive two different regions
-- or are feedthrough's from one region to the next. This prevents a single
-- net being placed "shorting" three regions together. Trusted Bus Macros
-- fulfilled this requirement automatically.

lut_reset_out : LUT1
GENERIC MAP (INIT => X"2")
PORT MAP (I0 => reset_i, O => reset_out );

lut_start_aes1_out : LUT1
GENERIC MAP (INIT => X"2")
PORT MAP (I0 => start_i, O => start_aes1 );

lut_start_aes2_out : LUT1
GENERIC MAP (INIT => X"2")
PORT MAP (I0 => start_i, O => start_aes2 );

lut_load_aes1_out : LUT1
GENERIC MAP (INIT => X"2")
PORT MAP (I0 => load_i, O => load_aes1 );

lut_load_aes2_out : LUT1
GENERIC MAP (INIT => X"2")
PORT MAP (I0 => load_i, O => load_aes2 );
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13. Right-click on the Synthesize-XST icon in the Processes window and select Process 
Properties (see Figure 2-28).

14. Set the Optimization Goal to Area and the Optimization Effort to High.

15. Click OK.

16. To run XST synthesis, either right-click on the Synthesize-XST icon in the Processes 
window and select Run, or double-click Synthesize-XST.

X-Ref Target - Figure 2-28

Figure 2-28: Process Properties
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17. After synthesis is complete, close the compare project.

Design Flow Progress
The Module Synthesis block of the SCC system design flow diagram is complete, as shown 
in Figure 2-29.
X-Ref Target - Figure 2-29

Figure 2-29: SCC System Design Flow with Module Synthesis Block Complete
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Project Entry in PlanAhead Tool

Launch the PlanAhead Tool
To launch the 12.1 version of the PlanAhead™ tool, select:

Start → All Programs → Xilinx ISE Design Suite 12.1 → PlanAhead → PlanAhead

PlanAhead Project Creation
The PlanAhead tool works with any synthesized netlist (XST, Synplify, etc.). The regular 
guidelines are followed to generate a new project and import the netlist into the 
PlanAhead tool to create a floorplan for the design.

1. Set up a new PlanAhead tool project (see Figure 3-1):

File → New Project
X-Ref Target - Figure 3-1

Figure 3-1: New Project
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2. Click Next and enter:

• Project name: For this lab, the FloorPlan_SCC project name is used.

• Project location: \Xilinx_Design\PlanAhead

3. Click Next.

4. Select Specify synthesized (EDIF or NGC) netlist (see Figure 3-2) because the 
modules have already been synthesized. To turn the project into a partially 
reconfigurable (PR) project, select Set PR Project. Click Next.

X-Ref Target - Figure 3-2

Figure 3-2: New Project (Design Source)
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5. Import the previously generated top-level netlist (see Figure 3-3).

6. Designate the top-level netlist and library directories. The netlist directories should 
include the static logic SCC_LAB_TOP.ngc and only one “version” of each PR or 
isolated (ISO) module.

Netlist File: 

..\Xilinx_Design\synthesis\SCC_LAB_TOP\SCC_LAB_TOP.ngc

Netlist Directories: 

..\Xilinx_Design\synthesis\aes

..\Xilinx_Design\synthesis\aes_r

..\Xilinx_Design\synthesis\compare

7. Click Next.

X-Ref Target - Figure 3-3

Figure 3-3: New Project (Import Netlist)
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8. This lab creates the final user constraints file (UCF) from the beginning. Thus no UCF 
files need to be imported, as shown in Figure 3-4. Click Next.

X-Ref Target - Figure 3-4

Figure 3-4: New Project (Import Constraints)
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9. Choose the product, family, and sub-family for the default part (see Figure 3-5). For 
this lab, Virtex5 LX is used.

10. Choose the device specifics:

a. Select the FF676 package

b. Select the -2 speed grade

c. Select the C temperature grade

d. Select the xc5vlx85ff676-2 device

11. Click Next.

X-Ref Target - Figure 3-5

Figure 3-5: New Project (Product Family and Floorplan)
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12. Figure 3-6 shows the New Project Summary screen, for review of the part and product 
family for the new project.

13. Click Finish.

X-Ref Target - Figure 3-6

Figure 3-6: New Project (New Project Summary)
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14. The PlanAhead tool project is created. Figure 3-7 shows the PlanAhead tool Project 
Manager window and the Open Netlist Manager window for the FloorPlan_SCC 
project.

15. To open the netlist design in the PlanAhead tool, under the Project Manager pane on 
the left, select Netlist Design → Open Netlist Design....

16. Set the design name to SCC_LAB_1. Click OK.

X-Ref Target - Figure 3-7

Figure 3-7: PlanAhead Tool Project Manger Window (Open Netlist Design)
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17. The PlanAhead tool project now looks as shown in Figure 3-8.

18. The project was turned into a PR project in step 4; therefore, the File → Set PR Project 
option is grayed out to indicate that this step has been completed.

X-Ref Target - Figure 3-8

Figure 3-8: PlanAhead Project View
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Placing I/Os with the PlanAhead Tool
When placing I/Os, it is imperative to consider the physical location of I/Os in relation to 
the logic regions they interface with. For example, the clock input can be placed anywhere 
because it does not have to be isolated. Because the LED pin is part of the compare logic, 
it needs to be physically placed in that region. Similarly, the reset and push_button pins are 
owned by the aes logic, so they need to be physically placed inside that region. To place 
the PlanAhead tool in site constraint mode:

1. Select the symbol shown in Figure 3-9 that is on the vertical shortcut bar between the 
netlist window and the device window.

X-Ref Target - Figure 3-9

Figure 3-9: Select Site Constraint Mode Symbol
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2. Select Edit → Find (shortcut: Ctrl-F). A Find window appears, as shown in 
Figure 3-10.

3. Select Sites from the Find pull-down menu.

4. Select Name and matches from the two pull-down menus under Criteria.

5. Type F14 in the remaining field box and click OK.

The search results appear on a tab in the Find Results section at the bottom left of the 
PlanAhead tool window.

X-Ref Target - Figure 3-10

Figure 3-10: Find
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6. Select the result and press F9 to zoom to the current selection, as shown in Figure 3-11. 
Alternatively, select View → Fit Selection from the top menu bar to perform the same 
task.

X-Ref Target - Figure 3-11

Figure 3-11: Find Results
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7. Select Edit → Find (shortcut: Ctrl-F). A Find window appears, as shown in 
Figure 3-12.

8. Select Ports from the Find pull-down menu.

9. Select Name and matches from the two pull-down menus under Criteria.

10. Type clk in the field box, and click OK. The search results appear on a tab in the Find 
Results section at the bottom left of the PlanAhead tool window.

X-Ref Target - Figure 3-12

Figure 3-12: Find
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11. Click and drag the result clk to the site identified in step 2 through step 6, as shown in 
Figure 3-13.

12. Repeat step 1 to step 11 to place “reset” at D11.

13. Repeat step 1 to step 11 to place “push_button” at D10.

14. Repeat step 1 to step 11 to place “led” at P6.

X-Ref Target - Figure 3-13

Figure 3-13: Drag clk
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Placing DCM with the PlanAhead Tool
These steps describe how to place the digital clock manager (DCM) using the 
PlanAhead tool:

1. Select Edit → Find (shortcut: Ctrl-F) and select Sites from the Find pull-down menu.

2. Select Name and matches from the two pull-down menus under Criteria (see 
Figure 3-14).

3. Type DCM_ADV_X0Y8 in the field box, and click OK.

The search results appear on a tab in the Find Results section at the bottom left of the 
PlanAhead tool window.

X-Ref Target - Figure 3-14

Figure 3-14: Find
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4. Select this result and press F9 to zoom to the current selection. The PlanAhead tool 
then zooms to the selected location (see Figure 3-15). Alternatively, select View → Fit 
Selection from the top menu bar to perform the same task.

X-Ref Target - Figure 3-15

Figure 3-15: Search Results
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5. In the Netlist window, expand Primitives, then drag TOP_DCM_ADV to the 
DCM_ADV_X0Y8 box, as shown in Figure 3-16.

6. Repeat step 1 through step 5 to place TOP_CLK0_BUFG at BUFGCTRL_X0Y31.

7. Repeat step 1 through step 5 to place the TOP_CLKDEV_BUFG at 
BUFGCTRL_X0Y30.

X-Ref Target - Figure 3-16

Figure 3-16: DCM_ADV_X0Y8
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Setting Up Timing Constraints with the PlanAhead Tool
This section shows that timing constraints can be applied to each module and the top-level 
design easily with the PlanAhead tool.

1. Select the Timing Constraints tab in the Netlist Design window, and click the Create 
New Constraint button located at the top of the Netlist/Constraints window (see 
Figure 3-17).

X-Ref Target - Figure 3-17

Figure 3-17: Create New Constraint
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2. Add a basic period constraint of 20 ns to the design by entering the value as shown in 
Figure 3-18.

3. Click OK.

4. Create a new timing constraint for Input pad to clk offset. Check the Delay value box 
and add a global input constraint of 6 ns to the design by entering the value as shown 

X-Ref Target - Figure 3-18

Figure 3-18: New Timing Constraint
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in Figure 3-19.

5. Click OK.

6. Create a new timing constraint for Clk to output pad offset. Check the Delay value box 
and add a global output constraint of 6 ns to the design by entering the value as shown 

X-Ref Target - Figure 3-19

Figure 3-19: New Timing Constraint
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in Figure 3-20.

7. Click OK.

X-Ref Target - Figure 3-20

Figure 3-20: New Timing Constraint (Delay Value)
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Defining RP or ISO Partitions with the PlanAhead Tool
Each partition must be turned into either a reconfigurable partition (RP) or an ISO partition 
as follows:

1. Select and right-click on U1_AES (aes) in the Netlist tab and select Set Partition from 
the pull-down menu (see Figure 3-21).

2. The Set Partition wizard opens. Click Next.
X-Ref Target - Figure 3-21

Figure 3-21: Set Partition
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3. Select is a reconfigurable Partition, as shown in Figure 3-22. Click Next.

4. Keep the default name at module_1. If there are to be multiple configurations for this 
block, the user should change the field to a more descriptive name for that specific 
configuration. Click Next.

X-Ref Target - Figure 3-22

Figure 3-22: Set Partition (Set Reconfigurable Partition)
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5. The Set Partition Summary screen is displayed, as shown in Figure 3-23. Click Finish.

6. Repeat step 1 through step 4 for the U2_AES2 (aes_r) partition.

7. Repeat step 1 through step 4 for the U3_Comp (compare) partition with the following 
exception:

Select the is a Partition option instead of the is a reconfigurable Partition option. 
The compare block is an ISO block, not an RP block. This option is selected in the Set 
Partition wizard screen (shown in Figure 3-22).

X-Ref Target - Figure 3-23

Figure 3-23: Set Partition (Set Reconfigurable Partition)
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8. A new Pblock must be created for the compare block. A Pblock is automatically 
created for RPs but not for ISO partitions. Select and right-click on U3_Comp 
(compare) in the Netlist tab and select New Pblock from the pull-down menu (see 
Figure 3-24). Keep the default name, pblock_U3_Comp, and click OK.

X-Ref Target - Figure 3-24

Figure 3-24: Create New Pblock for the U3_Comp (compare) Partition
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Defining Attributes for each RP or ISO Partition with the 
PlanAhead Tool

SCC rules have many additional constraint rules as opposed to a traditional PR flow. It is 
necessary to define several attributes for each partition:

1. Under the Netlist tab of the Netlist Design pane, select the U1_AES1 (aes) instance.

2. Under the Instance Properties window, select the Attributes tab for U1_AES1.

3. Select the Add pre-defined attributes... button (a green “+” symbol).

4. Select the SCC_ISOLATED attribute (see Figure 3-25).

5. Click OK.

X-Ref Target - Figure 3-25

Figure 3-25: Add Pre-defined Attributes (SCC_ISOLATED)
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6. In the Instance Properties window, scroll down to and check the box for the newly 
added SCC_ISOLATED attribute. Click Apply (see Figure 3-26).

7. Repeat step 1 through step 6 for the U2_AES2 (aes_r) instance.

8. Repeat step 1 through step 6 for the U3_Comp (compare) instance.

The PRIVATE attribute should be set for each pblock in the PlanAhead tool GUI as follows:

9. Under the Physical Constraints tab, select the pblock_U1_AES pblock, right-click 
on the selection, and click on Pblock Properties in the resulting menu.

10. Click on the Attributes tab of the Pblock Properties window, and click on the green 
“+” button to add pre-defined attributes.

11. Click on the PRIVATE attribute to select it, and click OK.

12. Select the attribute PRIVATE in the general attributes list in the Pblock Properties 
window, and select NONE.

13. Click Apply.

14. Repeat step 9 through step 13 for pblock_U2_AES2 and set PRIVATE to NONE.

15. Repeat step 9 through step 13 for pblock_U3_Comp and set PRIVATE to NONE.

X-Ref Target - Figure 3-26

Figure 3-26: Instance Properties (SCC_ISOLATED)
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Setting Up the Area Groups for the RP Regions with the 
PlanAhead Tool

These steps configure the area groups for the RP regions:

1. Under the Physical Constraints pane, select the block pblock_U1_AES1.

2. Right-click on pblock_U1_AES1 and select Set Pblock Size from the pull-down 
menu.

3. Draw a rectangle in the upper-left corner of the device window, as shown in 
Figure 3-27. (The rectangle does not have to be 100% accurate—it will be resized 
shortly.)

Note: The PlanAhead tool might resize the rectangles to many different combinations of 
smaller rectangles. The user needs only to ensure that there is one configurable logic block 
(CLB) of separation between the Pblocks AES1, AES2, and COMPARE.

X-Ref Target - Figure 3-27

Figure 3-27: Pblock Layout
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4. A dialog box (see Figure 3-28) appears with various attributes and associated 
checkboxes. All boxes must be checked, including (if listed) DCM_ADV, PLL_ADV, 
BUFGCTRL, BUFR, and BUFIO. Even though most of these blocks are not in the 
design, it is important to select them to take advantage of their routing resources. All 
used components must be included.

Note: Trusted Routing requires that all clocking components be assigned to the AREA GROUP 
that physically contains the component, even though the component is not logically instantiated 
in the HDL of that module.

5. Click OK.

6. In the Choose LOC mode dialog box, select the action Leave all location constraints 
in their current position.

7. Click OK.

8. Ensure that pblock_U1_AES1 is selected in the Physical Constraints pane.

X-Ref Target - Figure 3-28

Figure 3-28: Set Pblock
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9. Select the Rectangles tab in the Pblock Properties window (see Figure 3-29).

10. Adjust the rectangle graphically as necessary to match these coordinates:

X Lo = 0

Y Lo = 1

X Hi = 63

Y Hi = 65

11. Under the Physical Constraints tab, select the block pblock_U1_AES1.

12. Right-click on pblock_U1_AES1 and select Add Pblock Rectangle from the 
pull-down menu.

X-Ref Target - Figure 3-29

Figure 3-29: Pblock Properties
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13. Draw a rectangle in the upper center of the device window, as shown in Figure 3-30. 
(The rectangle does not have to be 100% accurate—it will be resized shortly.)

X-Ref Target - Figure 3-30

Figure 3-30: Pblock Layout
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14. A dialog box (see Figure 3-31) appears with various attributes and associated 
checkboxes. All boxes must be checked, including (if listed) DCM_ADV, PLL_ADV, 
BUFGCTRL, BUFR, and BUFIO. Even though most of these blocks are not in the 
design, it is important to select them to take advantage of their routing resources. All 
used components must be included.

Note: Trusted Routing requires that all clocking components be assigned to the AREA GROUP 
that physically contains the component, even though the component is not logically instantiated 
in the HDL of that module.

15. Click OK.

16. Ensure that pblock_U1_AES1 is selected in the Physical Constraints pane.

X-Ref Target - Figure 3-31

Figure 3-31: Add Rectangle
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17. Select the Rectangles tab in the Pblock Properties window (see Figure 3-32).

18. Adjust the rectangle graphically as necessary to match these coordinates:

X Lo = 65

Y Lo = 1

X Hi = 109

Y Hi = 31

19. Under the Physical Constraints tab, select the block pblock_U1_AES1.

20. Right-click on pblock_U1_AES1 and select Add Pblock Rectangle from the 
pull-down menu.

X-Ref Target - Figure 3-32

Figure 3-32: Pblock Properties
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21. Draw a rectangle in the upper right of the device window, as shown in Figure 3-33. 
(The rectangle does not have to be 100% accurate—it will be resized shortly.)

X-Ref Target - Figure 3-33

Figure 3-33: Pblock Layout
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22. A dialog box (see Figure 3-34) appears with various attributes and associated 
checkboxes. All boxes must be checked, including (if listed) DCM_ADV, PLL_ADV, 
BUFGCTRL, BUFR, and BUFIO. Even though most of these blocks are not in the 
design, it is important to select them to take advantage of their routing resources. All 
used components must be included.

Note: Trusted Routing requires that all clocking components be assigned to the AREA GROUP 
that physically contains the component, even though the component is not logically instantiated 
in the HDL of that module.

23. Click OK.

24. Ensure that pblock_U1_AES1 is selected in the Physical Constraints pane.

X-Ref Target - Figure 3-34

Figure 3-34: Add Rectangle
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25. Select the Rectangles tab in the Pblock Properties window (see Figure 3-35).

26. Adjust the rectangle graphically as necessary to match these coordinates:

X Lo = 112

Y Lo = 1

X Hi = 155

Y Hi = 53

27. Under the Physical Constraints tab, select the block pblock_U2_AES2.

28. Right-click on pblock_U2_AES2 and select Set Pblock Size from the pull-down 
menu.

X-Ref Target - Figure 3-35

Figure 3-35: Pblock Properties

X1105_c3_35_062210

http://www.xilinx.com


82 www.xilinx.com SCC Lab with Virtex-5 Family for ISE Tools 12.1
XAPP1105 (v1.1.2) June 19, 2013

Chapter 3: Floorplanning the System

29. Draw a rectangle in the lower left-hand corner of the device window, as shown in 
Figure 3-36. (The rectangle does not have to be 100% accurate—it will be resized 
shortly.)

X-Ref Target - Figure 3-36

Figure 3-36: Pblock Layout
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30. A dialog box (see Figure 3-37) appears with various attributes and associated 
checkboxes. All boxes must be checked, including (if listed) DCM_ADV, PLL_ADV, 
BUFGCTRL, BUFR, and BUFIO. Even though most of these blocks are not in the 
design, it is important to select them to take advantage of their routing resources. All 
used components must be included.

Note: Trusted Routing requires that all clocking components be assigned to the AREA GROUP 
that physically contains the component, even though the component is not logically instantiated 
in the HDL of that module.

31. Click OK.

32. Ensure that pblock_U2_AES2 is selected in the Physical Constraints pane.

X-Ref Target - Figure 3-37

Figure 3-37: Set Pblock

X1105_c3_37_06221 0

http://www.xilinx.com


84 www.xilinx.com SCC Lab with Virtex-5 Family for ISE Tools 12.1
XAPP1105 (v1.1.2) June 19, 2013

Chapter 3: Floorplanning the System

33. Select the Rectangles tab in the Pblock Properties window (see Figure 3-38).

34. Adjust the rectangle graphically as necessary to match these coordinates:

X Lo = 0

Y Lo = 68

X Hi = 63

Y Hi = 131

35. Under the Physical Constraints tab, select the block pblock_U2_AES2. 

36. Right-click on pblock_U2_AES2 and select Add Pblock Rectangle from the 
pull-down menu.

X-Ref Target - Figure 3-38

Figure 3-38: Pblock Properties
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37. Draw a rectangle in the lower center of the device window, as shown in Figure 3-39. 
(The rectangle does not have to be 100% accurate—it will be resized shortly.)

38. A dialog box (see Figure 3-40) appears with various attributes and associated 
checkboxes. All boxes must be checked, including (if listed) DCM_ADV, PLL_ADV, 
BUFGCTRL, BUFR, and BUFIO. Even though most of these blocks are not in the 
design, it is important to select them to take advantage of their routing resources. All 
used components must be included.

Note: Trusted Routing requires that all clocking components be assigned to the AREA GROUP 
that physically contains the component even though the component is not logically instantiated in 
the HDL of that module.

X-Ref Target - Figure 3-39

Figure 3-39: Pblock Layout

X-Ref Target - Figure 3-40

Figure 3-40: Add Rectangle
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39. Click OK.

40. Ensure that pblock_U2_AES2 is selected in the Physical Hierarchy pane.

41. Select the Rectangles tab in the Pblock Properties window (see Figure 3-41).

42. Adjust the rectangle graphically as necessary to match these coordinates:

X Lo = 65

Y Lo = 101

X Hi = 109

Y Hi = 131

43. Under the Physical Constraints tab, select the block pblock_U2_AES2.

44. Right-click on pblock_U2_AES2 and select Add Pblock Rectangle from the 
pull-down menu.

X-Ref Target - Figure 3-41

Figure 3-41: Pblock Properties
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45. Draw a rectangle in the lower right of the device window, as shown in Figure 3-42. 
(The rectangle does not have to be 100% accurate—it will be resized shortly.)

X-Ref Target - Figure 3-42

Figure 3-42: Pblock Layout
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46. A dialog box (see Figure 3-43) appears with various attributes and associated 
checkboxes. All boxes must be checked, including (if listed) DCM_ADV, PLL_ADV, 
BUFGCTRL, BUFR, and BUFIO. Even though most of these blocks are not in the 
design, it is important to select them to take advantage of their routing resources. All 
used components must be included.

Note: Trusted Routing requires that all clocking components be assigned to the AREA GROUP 
that physically contains the component, even though the component is not logically instantiated 
in the HDL of that module.

47. Click OK.

48. Ensure that pblock_U2_AES2 is selected in the Physical Constraints pane.

X-Ref Target - Figure 3-43

Figure 3-43: Add Rectangle
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49. Select the Rectangles tab in the Pblock Properties window (see Figure 3-44).

50. Adjust the rectangle graphically as necessary to match these coordinates:

X Lo =112 

Y Lo = 79

X Hi = 155

Y Hi = 131

51. Under the Physical Constraints tab, select the block pblock_U3_Comp.

52. Right-click on pblock_U3_Comp and select Set Pblock Size from the pull-down 
menu.

X-Ref Target - Figure 3-44

Figure 3-44: Pblock Properties
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53. Draw a rectangle in the center of the device window, as shown in Figure 3-45. (The 
rectangle does not have to be 100% accurate—it will be resized shortly.)

X-Ref Target - Figure 3-45

Figure 3-45: Pblock Layout
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54. A dialog box (see Figure 3-46) appears with various attributes and associated 
checkboxes. All boxes must be checked, including (if listed) DCM_ADV, PLL_ADV, 
BUFGCTRL, BUFR, and BUFIO. Even though most of these blocks are not in the 
design, it is important to select them to take advantage of their routing resources. All 
used components must be included.

Note: Trusted Routing requires that all clocking components be assigned to the AREA GROUP 
that physically contains the component, even though the component is not logically instantiated 
in the HDL of that module.

55. Click OK.

56. In the Choose LOC mode dialog box, select the action Leave all location constraints 
in their current position.

X-Ref Target - Figure 3-46

Figure 3-46: Set Pblock
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57. Click OK.

58. Ensure that pblock_U3_Comp is selected in the Physical Constraints pane.

59. Select the Rectangles tab in the Pblock Properties window (see Figure 3-47).

60. Adjust the rectangle graphically as necessary to match these coordinates:

X Lo = 67

Y Lo = 34

X Hi = 107

Y Hi = 98

61. Under the Physical Constraints tab, select the block pblock_U3_Comp.

62. Right-click on pblock_U3_Comp and select Add Pblock Rectangle from the 
pull-down menu.

X-Ref Target - Figure 3-47

Figure 3-47: Pblock Properties
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63. Draw a rectangle in the center right of the device window, as shown in Figure 3-48. 
(The rectangle does not have to be 100% accurate—it will be resized shortly.)

X-Ref Target - Figure 3-48

Figure 3-48: Pblock Layout
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64. A dialog box (see Figure 3-49) appears with various attributes and associated 
checkboxes. All boxes must be checked, including (if listed) DCM_ADV, PLL_ADV, 
BUFGCTRL, BUFR, and BUFIO. Even though most of these blocks are not in the 
design, it is important to select them to take advantage of their routing resources. All 
used components must be included.

Note: Trusted Routing requires that all clocking components be assigned to the AREA GROUP 
that physically contains the component, even though the component is not logically instantiated 
in the HDL of that module.

65. Click OK. 

66. Ensure that pblock_U3_Comp is selected in the Physical Constraints pane.

X-Ref Target - Figure 3-49

Figure 3-49: Add Rectangle
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67. Select the Rectangles tab in the Pblock Properties window (see Figure 3-50).

68. Adjust the rectangle graphically as necessary to match these coordinates:

X Lo = 109

Y Lo = 56

X Hi = 155

Y Hi = 76

X-Ref Target - Figure 3-50

Figure 3-50: Pblock Properties
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69. The final layout is shown in Figure 3-51. Each block is separated by one CLB to ensure 
SCC isolation. A block RAM, DSP, IOB, or any other site type that contains a Global 
Switch Matrix (GSM) can be used for this isolation.

70. Ensure that there is one CLB of spacing between each area group.

X-Ref Target - Figure 3-51

Figure 3-51: Final Layout
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Design Flow Progress
The System Floorplanning block of the SCC system design flow diagram is complete, as 
shown in Figure 3-52.
X-Ref Target - Figure 3-52

Figure 3-52: SCC System Design Flow with System Floorplanning Block Complete
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Running Report Timing with the PlanAhead Tool
This section tests the timing constraints that were set up in Setting Up Timing Constraints 
with the PlanAhead Tool, page 63.

1. Select Tools → Report Timing and click OK (see Figure 3-53).

2. A new tab, Timing Results, appears at the bottom with a sub-tab named as specified in 
the Run TimeAhead window (results_1 in this case). As specified when launched, 
TimeAhead reports the 10 paths closest to missing timing.

X-Ref Target - Figure 3-53

Figure 3-53: Report Timing Dialog Box
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Design Flow Progress
The Timing Analysis block of the SCC system design flow diagram is complete, as shown 
in Figure 3-54.

Exporting the Design
At this stage, the design can be exported. The user can export either the combined netlist in 
EDIF form, the top-level UCF, or both, if desired. For this lab, only the UCF need be 
exported for checking by the Isolation Verification Tool.

1. To export the netlist, select File → Export Netlist.

2. Browse to the ..\Xilinx_Design\PlanAhead directory and keep the default 
filename FloorPlan_SCC.edf.

3. Click OK.

4. To export the constraints file, select File → Export Constraints and browse to the 
desired location or choose the default location 
..\Xilinx_Design\PlanAhead\FloorPlan_SCC\SCC_Lab_1.ucf.

5. Click OK.

X-Ref Target - Figure 3-54

Figure 3-54: SCC System Design Flow with Timing Analysis Block Complete
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Chapter 4

Running the Isolation Verification Tool 
Against the UCF

The Xilinx® Isolation Verification Tool (IVT) software verifies that an FPGA design that has 
been partitioned into isolated modules meets the stringent standards for a fail-safe design. 
IVT is a batch application with a command line and file-based user interface. While there is 
a graphical output, there is no graphical user interface.

While not required, it is highly recommended that the user run IVT on the UCF. This can 
catch pin and area group isolation faults early in the design when changes are more easily 
integrated. The steps in this chapter guide the reader through the process. After 
implementation, the IVT native circuit description (NCD) test (required for SCC designs) is 
run against the routed design.

Creating the File Used to Run the IVT UCF Test
These steps describe how to create the file used to run the IVT UCF test:

1. Open the directory ..\Xilinx_Design\ivt.

2. The ivt.zip file posted on the Isolation Design Flow page contains the files needed 
for IVT:

• ivt.exe – the IVT executable for IVT

• IVT_End_User_License_Agreement.pdf – the IVT user license

3. Create a new text file and name the file SCC-LAB_ucf.ivt with these contents:

-device xc5vlx85 -package ff676

# Groups               Isolation Group             Area Group
# -------  -------------------- ---------------------
-group AES pblock_U1_AES1
-group AES_r pblock_U2_AES2
-group COMPARE pblock_U3_Comp

# Pin Isolation Groups
-pig SCC-LAB.pig

# User Constraint File
..\PlanAhead\Floorplan_SCC\SCC_LAB.ucf

# Output file
-output SCC-LAB_ucf.rpt

4. Notice the instructions placed in the IVT command file:

a. The first line sets the target device and package for IVT to compare against.
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b. Three isolation groups are assigned: AES, AES_r, and COMPARE.

Note: These names are arbitrary. If desired they can be named the same to denote RED 
and BLACK groups.

c. Three area groups are assigned: pblock_U1_AES1, pblock_U2_AES2, and 
pblock_U3_Comp.

Note: These names must match the area groups in the UCF.

d. IVT points to the UCF.

e. IVT is told where to place the output file and its associated name.

5. Save and close the IVT command file.

Creating the Pin Isolation Group File
The pin isolation group (PIG) file is an IVT command file that defines which pins are 
associated with what isolation groups. These steps describe the process for creating a PIG 
file:

1. Open the directory ..\Xilinx_Design\ivt.

2. Create or modify a text file and name the file SCC-LAB.pig with these contents:

# Place all Global (top level) signals here (each commented out)
# NET "clk" LOC = F14;

ISOLATION _GROUP AES BEGIN
NET "reset" LOC = D11;
NET "push_button" LOC = D10;

END ISOLATION_GROUP

ISOLATION_GROUP AES_r BEGIN
# There are no pins in AES_r
END ISOLATION_GROUP

ISOLATION_GROUP COMPARE BEGIN
NET "led" LOC = P6;

END ISOLATION_GROUP

3. Notice the instructions placed in the IVT PIG file:

a. The clock pin, clk, is commented out because it is not required to be isolated.

b. The three isolation groups that were created in the IVT UCF command file have 
their associated pins assigned to them.

4. The isolation group definitions must match the isolation group definitions from the 
IVT command created in Creating the File Used to Run the IVT UCF Test.

Hint: The IVT PIG file uses UCF syntax for each pin definition. It is useful to copy the 
pins from the UCF and place them in the PIG file as a starting point. From there, the 
user can either comment out the lines at the top level or add isolation group definitions 
around the remaining pins to assign them to their specific isolation group.

Running the IVT UCF Test
These steps describe how to run the IVT UCF test:

1. Open a DOS command prompt (Start → Run → cmd).

2. Navigate to the ..\Xilinx_Design\ivt directory.
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3. Run the UCF test by typing the following at the command prompt:

ivt -f SCC-LAB_ucf.ivt

4. The output for a successful UCF test run is “SUCCESS!”.

5. For more detailed messages from IVT, add the -verbose switch to the IVT command 
file or at the command line.

Hint: It is useful to add this command line to a file with the name run_ivt_ucf.bat 
so that it can be double-clicked from a Windows Explorer window. A sample of this file 
can be found in the ../ivt directory.

Examining the Output from the IVT UCF Test
The output report has five key sections:

1. Isolation Groups and Area Groups

2. Pin Isolation Summary

Die Pin Adjacency Violations: 0
Package Pin Adjacency Violations: 0
Bank Isolation Violations: 0

3. Area Fault Summary

Area Group Faults: 0

4. Isolation Verification Summary

UCF file contains 0 constraint violations.
Isolation analysis completed.
Elapsed time: 0:00:03
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Design Flow Progress
The IVT on UCF File block of the SCC system design flow diagram is complete, as shown 
in Figure 4-1.
X-Ref Target - Figure 4-1

Figure 4-1: SCC System Design Flow with IVT on UCF File Block Complete
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Chapter 5

Implementing the Design with the 
PlanAhead Tool

Generating and Running an Implementation
These steps describe how to generate and run a design implementation(1):

1. From the Project Manager pane in the PlanAhead™ tool:

a. Select Implement → Implementation Settings... (see Figure 5-1).

1. To implement a design using the PlanAhead tool 12.1, refer to the process detailed in Appendix A, Modified 
Implementation of the PlanAhead Tool 12.1.

X-Ref Target - Figure 5-1

Figure 5-1: Implement Design (Implementation Settings)
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b. An Implementation Settings dialog box appears (see Figure 5-2). To launch a run, 
accept the defaults and click Run.

2. A new tab named Design Runs is created, and a single entry named config_1 is 
generated. It immediately starts the run: NGDBUILD → MAP → Place and Route.

3. An Implementation Completed dialog box appears after the design run is completed. 
Select the Open Implemented Design option and click OK.

X-Ref Target - Figure 5-2

Figure 5-2: Implementation Settings
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4. The Device tab in the Design Planner pane shows the placed, routed, and partitioned 
design (see Figure 5-3).

5. The combined and routed design is placed in this directory:

..\Xilinx_Design\PlanAhead\FloorPlan_SCC\FloorPlan_SCC.runs\config_1

The file name is config_1_routed.ncd and its view in FPGA Editor is shown in 
Figure 5-4.

X-Ref Target - Figure 5-3

Figure 5-3: Implemented and Floorplanned Design
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X-Ref Target - Figure 5-4

Figure 5-4: FPGA Editor View
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Design Flow Progress
The Design Implementation block of the SCC system design flow diagram is complete, as 
shown in Figure 5-5.
X-Ref Target - Figure 5-5

Figure 5-5: SCC System Design Flow with Design Implementation Block Complete
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Chapter 6

Verifying the Design with the NCD 
Isolation Verification Tool

Creating the File Used to Run the IVT NCD Test
These steps describe how to create the file used to run the IVT NCD test:

1. Open the directory \Xilinx_Design\ivt\.

2. Create a new text file in the \Xilinx_Design\ivt\ directory:

SCC-LAB_ncd.ivt

3. Open the text file SCC-LAB_ncd.ivt in a text editor.

4. Add these lines to the SCC-LAB_ncd.ivt text test file.

# comment the next line for reduced detail in the report file.
-verbose
# Groups    Isolation Group     Instance Name in Final NCD
# -------- ---------------- --------------------------
-group AES U1_AES1
-group AES_r U2_AES2
-group COMPARE U3_Comp

# Combined design
..\PlanAhead\FloorPlan_SCC\FloorPlan_SCC.runs\impl\floorplans\
fp_v5lx85_ff676-2_1\impl_1\impl_1_routed.ncd

# Output Report File
-output SCC-LAB_ncd.rpt

The NCD IVT command file sets these options:

• Enables the verbose IVT switch

• Assigns three area groups to the three NCD files making up the project

• Points the IVT tool to the combined NCD file

• Tells IVT what to name the output report file and where to put the file

Note: The Isolation Group names are arbitrary, but the instance name must match the actual 
design.
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Running the IVT NCD Test
These steps describe how to run the IVT NCD test:

1. Open a command prompt (Start → Run → cmd).

2. Navigate to the \Xilinx_Design\ivt\ directory.

3. To run the IVT NCD test, type the following at the command prompt:

ivt -f SCC-LAB_ncd.ivt

4. The output for a successful NCD test run is “SUCCESS!”.

Examining the Output from the IVT NCD Test
IVT creates two types of output files. The standard RPT file is a text report file. The SVG 
output file is a graphical view of the Virtex®-5 device with colored tiles denoting the 
ownership of the tiles by each isolated or PR area.

IVT RPT Output File
These steps describe how to read the various sections of the RPT output file from the IVT 
NCD test:

1. Open the IVT NCD test output file:

\Xilinx_Design\ivt\SCC-LAB_ncd.rpt

All the groups are listed in the input designs section:

Input Designs

Group AES module: U1_AES1
Group AES_r module: U2_AES2
Group COMPARE module: U3_Comp

2. Ensure that Clocks and Resets are listed in the Unidentified Shared Networks section. 
For SCC Trusted Routing designs, signals shared between isolated regions are 
expected and intended and will show up here. An example of global signals are the 
following Global Clock signals, which are expected to be shared outside of an isolated 
region:

Unidentified Shared Networks

The networks below are found in multiple isolation groups, therefore it 
is incumbent upon the user to prove these signals do not violate data 
isolation requirements. Only power, ground, bus macros, global resets 
or explicitly permitted control signals may be shared.

clk_ibufg
clk0_buf
clkdev_buf

3. In the Identified Networks section, ensure that all remaining Clocks are listed in the 
Networks Driven by Global Clock Sources section:

Networks Driven by Global Clock Sources (BUFG, DCM, PLL, and PMCD)

clk_fb_i
clk_i
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4. Notice that in the Identified Networks section, Shared Networks Attached to Bus 
Macros are listed, where applicable. All networks passing through Bus macros are 
considered safe by IVT and are listed in this section.

5. Ensure that only bus macros are listed in the bus macro usage summary.

6. Pay special attention to the package pins, I/O buffers, and I/O banks because the note 
states that the user must verify that pins connected to ignored networks are correct.

Package Pins, I/O Buffers, and I/O Banks

Note: It is incumbent on the user to verify that pins connected to ignored networks are correct. 
For example, pins must not be directly connected to bus macros, but pins can be connected to 
clocks, power, and global resets.

Pin(col, row)   Bank  I/O Buffer Isolation Group Network

------------- ---- ------------ ---------------   ------------------------

D10( 16,  22)  16 IOB_X2Y198 AES U1_AES1/push_button_IBUF

D11( 15,  22)  16 IOB_X2Y199    AES U1_AES1/reset_out

P6( 20,  12)   12 IOB_X2Y121    COMPARE U3_Comp/led_OBUF

F14( 12,  20) 3 IOB_X1Y179    ignored clk

The following output in the NCD report indicates that there are no faults in the NCD 
and lists the time it took to run the test:

Pin Isolation Summary

  Die Pin Adjacency Violations: 0
  Package Pin Adjacency Violations: 0
  Bank Isolation Violations: 0

Isolation Verification Summary

  Design contains 0 constraint violations.

  Isolation analysis completed.

  Elapsed time: 0:03:35
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IVT SVG Output File
The SVG file created by IVT gives a graphical view of the Virtex-5 device with colored tiles 
denoting the ownership of the tiles by each isolated or PR region. The SVG file also visually 
highlights that there is a proper fence isolating each of the regions (uncolored tiles). 
Figure 6-1 shows the SVG output for the Virtex-5 FPGA design used in the SCC lab.
X-Ref Target - Figure 6-1

Figure 6-1: IVT SVG File Graphical Output
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The separate isolated regions can be easily recognized in the SVG graphical output and 
compared to the FPGA Editor screen capture shown in Figure 1-4, page 9, or the 
PlanAhead™ tool floorplan screen capture shown in Figure 5-3, page 107. The SVG format 
was chosen because it is a standard format that can be read by a web browser (such as 
Microsoft Internet Explorer or Mozilla Firefox) or by Microsoft Visio.

Design Flow Progress
The SCC lab is complete with the IVT on NCD File block of the flow diagram, as shown in 
Figure 6-2.
X-Ref Target - Figure 6-2

Figure 6-2: SCC System Design Flow with IVT on NCD File Block Complete
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Appendix A

Modified Implementation of the 
PlanAhead Tool 12.1

Due to a software issue in the PlanAhead™ tool 12.1, a workaround is required for 
modifying the UCF and then running implementation. The PlanAhead tool, which is used 
to generate the batch file for implementation, erroneously puts three SCC_ISOLATED 
instances into the generated UCF file during implementation. The user thus has to modify 
the UCF file generated by the PlanAhead tool. The generated batch script is run to 
implement the design. (The design should not be implemented using the PlanAhead tool 
because the UCF file is regenerated with the SCC_ISOLATED instances put back in, and 
implementation thus fails at ngdbuild.)
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Implementing the Design Using the PlanAhead Tool 12.1 and the 
Generated Batch Script File

This section describes the steps required to implement the reference design using the 
PlanAhead tool 12.1.

1. From the Project Manager pane in the PlanAhead tool, select Implement →  
Implementation Settings... (see Figure A-1).

X-Ref Target - Figure A-1

Figure A-1: Implement Design (Implementation Settings)
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2. The Implementation Settings dialog box appears (see Figure A-2). This is not used to 
launch a run, but is only used to generate the batch script files. In the Implementation 
Settings dialog box, browse the Launch Options menu. In the Specify Launch Options 
dialog box, select the Generate scripts only option.

3. Click OK on the Specify Launch Options dialog box and then click Run on the 
Implementation Settings dialog box.

4. Modify the UCF file generated by the PlanAhead tool in the 
..\PlanAhead\FloorPlan_SCC\FloorPlan_SCC.runs\config_1 directory. 
Open the UCF in a text editor and remove these three instances:

INST "U1_AES1" SCC_ISOLATED = "TRUE";
INST "U2_AES2" SCC_ISOLATED = "TRUE";
INST "U3_Comp" SCC_ISOLATED = "TRUE";

5. Save and close the UCF file.

6. Navigate to the 
..\PlanAhead\FloorPlan_SCC\FloorPlan_SCC.runs\config_1 directory.

X-Ref Target - Figure A-2

Figure A-2: Implementation Settings (Specify Launch Options)
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7. Run the batch script file created by the PlanAhead tool. Launch the runme file (.bat 
or .sh, depending on the platform).

Note: If the project is open in the PlanAhead tool when the batch file is run, the implementation 
process can be monitored through the PlanAhead tool as if the implementation were initiated via 
the PlanAhead tool.

8. The routed NCD file config_1_routed.ncd that is used to run IVT on NCD File can 
be found in the 
..\PlanAhead\FloorPlan_SCC\FloorPlan_SCC.runs\config_1 directory.

9. If the implementation is being monitored in the PlanAhead tool, an Implementation 
Completed dialog box appears after the design run is completed. Select the Open 
Implemented Design option and click OK.

10. The Device tab in the Design Planner pane shows the placed, routed, and partitioned 
design (see Figure 5-3, page 107).
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